Solution of OpenGL initialization failure after upgrading motherboard and CPU

Some time ago, the motherboard and CPU were replaced, and the graphics card was displayed as the CPU core. Because there were a lot of programs, there was no new installation system, but under the old system. The previous programs were completely retained and patched again, and everything looked perfect.
It was not until I played Angry Birds that I found that OpenGL was not working. I suspected that it was a driver problem. Updating the graphics card driver to the latest version still failed. Google has tried countless solutions, but they don’t work. Using the GPU CAPS Viewer, the OpenGL driver was not found.
Occasionally see an article that logout users, with another account login can use OpenGL, remember there is an account, immediately logout after using another account login system, found that OpenGL is really available.
What’s the problem?This must be because the user’s configuration is different, so we export the HKCU in the two users’ registries into reg files, compare the two files with TotalCommander, search OpenGL, and find that there are more in the new registry
[HKEY_CURRENT_USER\Software\Intel\Display\CUICOM], another active reg file does not have it, so try to remove it altogether.
Start the GPU CAPS Viewer again and see that the OpenGL driver is correct, version 3.1. The problem that had troubled us for several days was finally solved.

Conclusion: After the replacement of the graphics card, the old registry key is not deleted. There are two Intel graphics card configurations in HKCU. It is concluded that the system uses the first one to initialize OpenGL, which of course fails.


Read More: