Yard error: found incompatible module

When I install the project with yarn, the error is as follows:

error [email protected] : The engine “node” is incompatible with this module. Expected version “>=4 <=9”. Got “10.15.3”
error Found incompatible module

reference resources: https://www.jianshu.com/p/5cb4f48ed11b

In addition, please refer to: http://quabr.com/53025664/error-eslint5-6-0-the-engine-node-is-incompatible-with-this-module-when-try

Set yarn as follows:

yarn config set ignore-engines true

Re install the project package and find that there are still problems.

Delete node_ Modules package and yarn.lock File, restart yarn install.

success.


Read More: