Maven of springboot project pom.xml Unknown error in the first line of the file

Reason: the plug-in version of Maven is not compatible with IDE

Solution: add & lt; Maven jar to POM- plugin.version&gt ;3.1.1</maven-jar- plugin.version&gt That’s all

    <properties>
        < java.version&gt ;1.8         <spring- cloud.version&gt ; Greenwich.SR1&lt ;/spring- cloud.version&gt ;
        <maven-jar- plugin.version&gt ;3.1.1</maven-jar- plugin.version&gt ;
    </properties>


Read More: