compile error: error in parse transform ‘lager_transform‘

The lager package is used in Erlang project. Version 20 was used before OTP, but now it is upgraded to version 24. There is an error in compiling make,

compile error: error in parse transform ‘lager_ transform’

Analysis shows that the lager version is low. Enter the rebar.config file and change the tag of lager to the latest version.

{lager, ".*", {git, "https://github.com/erlang-lager/lager", {tag, "3.9.1"}

Problem solving.

Reference article: https://github.com/erlio/vmq_ diversity/issues/12  


Read More: