ModuleNotFoundError: No module named ‘numpy.testing.nosetester‘

 File "/home/jsj201-6/anaconda3/lib/python3.6/site-packages/allennlp/data/data_loaders/multiprocess_data_loader.py", line 16, in <module>
    from allennlp.data.data_loaders.data_collator import DataCollator, DefaultDataCollator
  File "/home/jsj201-6/anaconda3/lib/python3.6/site-packages/allennlp/data/data_loaders/data_collator.py", line 3, in <module>
    from transformers.data.data_collator import DataCollatorForLanguageModeling
  File "/home/jsj201-6/anaconda3/lib/python3.6/site-packages/transformers/data/__init__.py", line 19, in <module>
    from .metrics import glue_compute_metrics, xnli_compute_metrics
  File "/home/jsj201-6/anaconda3/lib/python3.6/site-packages/transformers/data/metrics/__init__.py", line 23, in <module>
    from sklearn.metrics import f1_score, matthews_corrcoef
  File "/home/jsj201-6/anaconda3/lib/python3.6/site-packages/sklearn/metrics/__init__.py", line 7, in <module>
    from .ranking import auc
  File "/home/jsj201-6/anaconda3/lib/python3.6/site-packages/sklearn/metrics/ranking.py", line 25, in <module>
    from scipy.stats import rankdata
  File "/home/jsj201-6/anaconda3/lib/python3.6/site-packages/scipy/stats/__init__.py", line 348, in <module>
    from .stats import *
  File "/home/jsj201-6/anaconda3/lib/python3.6/site-packages/scipy/stats/stats.py", line 177, in <module>
    from . import distributions
  File "/home/jsj201-6/anaconda3/lib/python3.6/site-packages/scipy/stats/distributions.py", line 13, in <module>
    from . import _continuous_distns
  File "/home/jsj201-6/anaconda3/lib/python3.6/site-packages/scipy/stats/_continuous_distns.py", line 15, in <module>
    from scipy._lib._numpy_compat import broadcast_to
  File "/home/jsj201-6/anaconda3/lib/python3.6/site-packages/scipy/_lib/_numpy_compat.py", line 10, in <module>
    from numpy.testing.nosetester import import_nose
ModuleNotFoundError: No module named 'numpy.testing.nosetester'

terms of settlement:

Update the version of SciPy:

pip install numpy==1.18
pip install scipy==1.1.0
pip install scikit-learn==0.21.3

The problem is solved.


Read More: