[Solved] error: Microsoft Visual C++ 14.0 or greater is required

error: Microsoft Visual C++ 14.0 or greater is required. Get it with “Microsoft C++ Build Tools”: https://visualstudio.microsoft.com/visual-cpp-build-tools/

For the problem of error: Microsoft C + + build tools  error, most of the partners have tried to install Microsoft C + + build tools 3.13mb, but it seems that they can’t continue to use it at present. Here, the author provides a new version of Microsoft C + + build tools 2017/2019. This version of Microsoft C + + build tools is downward compatible with Microsoft C + + build tools. If you need, you can try it

First download: Microsoft Visual C + + build tools. If the link fails, you can go to to download from this link

Here, we only need to select visual c + + generation tool, and the installation location can be modified by ourselves

You can see that the installation size is about 4GB

The following errors may occur during the installation. This is only because there is no corresponding file. It is because of the library version problem. You can view it in the corresponding location or change the version to solve it (not a problem)

If there is no such problem, you can easily solve it by installing the python library again

Good luck!

 


Read More: