nginx: error while loading shared libraries: libluajit-5.1.so.2: cannot open

Installation steps:

1. Download and install luajit 2.1 (both 2.0 and 2.1 are supported, and 2.1 is officially recommended): http://luajit.org/download.html

cd /usr/local/src
wget http://luajit.org/download/LuaJIT-2.1.0-beta3.tar.gz
tar zxvf LuaJIT-2.1.0-beta3.tar.gz
cd LuaJIT-2.1.0-beta2
make PREFIX=/usr/local/luajit
make install PREFIX=/usr/local/luajit


Read More: