laravel Error mews/captcha is locked to version 3.2.4 and an update of this package was not requested.

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - mews/captcha is locked to version 3.2.4 and an update of this package was not requested.
    - mews/captcha 3.2.4 requires php ^7.2 -> your php version (8.0.1) does not satisfy that requirement.


Installation failed, reverting ./composer.json and ./composer.lock to their original content.

Resolve the version and ignore the version directly
Just follow this after your composer directive

--ignore-platform-reqs

For example, I installed BarryVDH/Laravel -debugbar appeared
Originally is:

composer require barryvdh/laravel-debugbar --dev

Change to install dependencies on success

composer require barryvdh/laravel-debugbar --dev --ignore-platform-reqs


Read More: