Idea error: error: Java: error: release 5 is not supported

When I test the class run, the following error occurs:

Possible cause: Java version inconsistencies The project builds the configuration using the wrong version of Java
Solution:
Step 1: File –Project Structure– Project (2 versions are changed to the same: the numbers in the second and third bars are 11)

File — –Project Structure– Modules (second bar changed from 9 to 11 as in Project)

Step 2: File– Setting– build, execution, deployment– Java Compiler (right-most, Target bytecode version 5)

 
 


Read More: