Composer require — dev barryvdh / laravel ide helper error resolution

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - barryvdh/laravel-ide-helper[dev-master, v2.9.0] require illuminate/console ^8 -> found illuminate/console[v8.0.0, ..
., 8.x-dev] but it conflicts with another require.
    - barryvdh/laravel-ide-helper 2.9.x-dev is an alias of barryvdh/laravel-ide-helper dev-master and thus requires it to
be installed too.
    - Root composer.json requires barryvdh/laravel-ide-helper ^2.9 -> satisfiable by barryvdh/laravel-ide-helper[v2.9.0, 2
.9.x-dev (alias of dev-master)].

Installation failed, reverting ./composer.json and ./composer.lock to their original content.

Since PHP 8 is out, this support depends on the version, and I currently have Laravel 7 installed, so the default version of Laravel-id-helper is not supported, we will install the lower version

composer require --dev barryvdh/laravel-ide-helper 2.8

Read More: