[Solved] error [email protected]: The engine “node” is incompatible with this module.

An error was reported when initializing the react project:

error [email protected]: The engine “node” is incompatible with this module. Expected version “^6.14.0 || ^8.10.0 || >=9.10.0”. Got “8.9.4”
error Found incompatible module
info Visit https://yarnpkg.com/en/docs/cli/add for documentation about this command.

This is caused by the incompatibility of the node version. Upgrading the node version can solve it, or it can be solved without upgrading. Use the following command:

npx create-react-app my-app  --use-npm


Official issues: https://github.com/facebook/create-react-app/issues/5714 and https://github.com/facebook/create-react-app/issues/3974


Guys, a few days ago, I installed `yarn` on my Mac just because it’s necessary for a project where I’m involved.

My problem is that, now, when I create a new app with `CRA`, it’s going to use `yarn` instead of `npm`. And, to be honest, I prefer `npm`.

Is there a way to force to use `npm` instead of `yarn`?
Or should I wait until finish the initial setup, then remove the `yarn.lock` file, the `node_modules` folder and then run `npm i`?


You can run CRA with `–use-npm` flag to force it to use npm.

Read More:

Leave a Reply

Your email address will not be published. Required fields are marked *