Springboot WARNING: An illegal reflective access operation has occurred

 

The warning is shown in the figure. The warning is because the jdk version is too high (I use 15.0, and it is said that it will be the same for 9.0). The specific principle has not been studied. It does not affect the normal operation of the project, but it looks very sad There is wood there~~~~

The solution is to reduce the project jdk to 1.8 and below, 1.8 is recommended.


Read More:

Leave a Reply

Your email address will not be published. Required fields are marked *