[Solved] Linux – error: cannot open Packages database in /var/lib/rpm

Error Message:

[[email protected]_0_17_centos rabbitmq]# yum install xxx.rpm
error: rpmdb: BDB0113 Thread/process 27590/140471762446144 failed: BDB1507 Thread died in Berkeley DB library
error: db5 error(-30973) from dbenv->failchk: BDB0087 DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db5 –  (-30973)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:
Error: rpmdb open failed

Solution:

[[email protected]_0_17_centos]# cd /var/lib/rpm
[[email protected]_0_17_centos rpm]# ls
Basenames  Conflictname  __db.001  __db.002  __db.003  Dirnames  Group  Installtid  Name  Obsoletename  Packages  Providename  Requirename  Sha1header  Sigmd5  Triggername
[[email protected]_0_17_centos rpm]# rm -rf __db*
[[email protected]_0_17_centos rpm]# rpm --rebuilddb


Read More: