Tag Archives: PHP installation

[Solved] error processing package libapache2-mod-php7.2

Error in installing libpciaccess:


Setting up php7.2-cli (7.2.24-0ubuntu0.18.04.11) ...
dpkg: error processing package php7.2-cli (--configure):
 installed php7.2-cli package post-installation script subprocess returned error exit status 10
No apport report written because MaxReports is reached already
                                                              Setting up python-libxml2 (2.9.4+dfsg1-6.1ubuntu1.5) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
dpkg: dependency problems prevent configuration of libapache2-mod-php7.2:
 libapache2-mod-php7.2 depends on php7.2-cli; however:
  Package php7.2-cli is not configured yet.

dpkg: error processing package libapache2-mod-php7.2 (--configure):
 dependency problems - leaving unconfigured
Setting up libsqlite0 (2.8.17-14fakesync1) ...
No apport report written because MaxReports is reached already
                                                              Setting up librpm8 (4.14.1+dfsg1-2) ...

... ...

Errors were encountered while processing:
 ufw
 nfs-common
 openssh-server
 php7.2-cli
 libapache2-mod-php7.2
E: Sub-process /usr/bin/dpkg returned an error code (1)

To view installation information:

 apt list | grep libapache2-mod-php

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libapache2-mod-php/bionic,bionic,now 1:7.2+60ubuntu1 all [installed]
libapache2-mod-php5filter/trusty 5.5.9+dfsg-1ubuntu4 amd64
libapache2-mod-php7.2/bionic-security,bionic-updates,now 7.2.24-0ubuntu0.18.04.11 amd64 [installed]

Just remove the contents reported as errors:

apt-get remove --purge libapache2-mod-php7.2
apt-get remove --purge nfs-common
apt-get remove --purge php7.2-cli
apt-get remove --purge ufw
apt-get remove --purge openssh-server
... ...

Upgrade list:

apt-get update

Review the installed information again and confirm remove:

apt list | grep libapache2-mod-php*

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

libapache2-mod-php/bionic,bionic 1:7.2+60ubuntu1 all
libapache2-mod-php5filter/trusty 5.5.9+dfsg-1ubuntu4 amd64
libapache2-mod-php7.2/bionic-security,bionic-updates,now 7.2.24-0ubuntu0.18.04.11 amd64 [residual-config]

Reinstall, done!:

apt install libpciaccess
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package libpciaccess
[email protected]:~/wk/bak_load/win2030/buildroot/dl$ sd apt-get install libpciaccess-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libpciaccess-dev is already the newest version (0.14-1).
The following packages were automatically installed and are no longer required:
  keyutils libnfsidmap2 libtirpc1 ncurses-term openssh-sftp-server php7.2-common php7.2-json php7.2-opcache php7.2-readline rpcbind ssh-import-id
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 32 not upgraded.