[Solved] K8s Install Error: docker-ce conflicts with 2:docker-1.13.1-208.git7d71120.el7_9.x86_64

Docker-CE

[[email protected] ~]#  yum list installed | grep docker
containerd.io.x86_64                       1.4.6-3.1.el7               @docker-ce-stable
docker-ce.x86_64                           3:20.10.7-3.el7             @docker-ce-stable
docker-ce-cli.x86_64                       1:20.10.7-3.el7             @docker-ce-stable
docker-ce-rootless-extras.x86_64           20.10.7-3.el7               @docker-ce-stable
docker-scan-plugin.x86_64                  0.8.0-3.el7                 @docker-ce-stable
[[email protected] ~]#  yum remove -y docker-ce*
Loaded plugins: fastestmirror, langpacks
Resolving Dependencies
--> Running transaction check
---> Package docker-ce.x86_64 3:20.10.7-3.el7 will be erased
---> Package docker-ce-cli.x86_64 1:20.10.7-3.el7 will be erased
--> Processing Dependency: docker-ce-cli for package: docker-scan-plugin-0.8.0-3.el7.x86_64
---> Package docker-ce-rootless-extras.x86_64 0:20.10.7-3.el7 will be erased
--> Running transaction check
---> Package docker-scan-plugin.x86_64 0:0.8.0-3.el7 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

================================================================================
 Package                    Arch    Version            Repository          Size
================================================================================
Removing:
 docker-ce                  x86_64  3:20.10.7-3.el7    @docker-ce-stable  115 M
 docker-ce-cli              x86_64  1:20.10.7-3.el7    @docker-ce-stable  156 M
 docker-ce-rootless-extras  x86_64  20.10.7-3.el7      @docker-ce-stable   24 M
Removing for dependencies:
 docker-scan-plugin         x86_64  0.8.0-3.el7        @docker-ce-stable   13 M

Transaction Summary
================================================================================
Remove  3 Packages (+1 Dependent package)

Installed size: 309 M
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Erasing    : docker-ce-rootless-extras-20.10.7-3.el7.x86_64               1/4 
  Erasing    : 3:docker-ce-20.10.7-3.el7.x86_64                             2/4 
  Erasing    : docker-scan-plugin-0.8.0-3.el7.x86_64                        3/4 
  Erasing    : 1:docker-ce-cli-20.10.7-3.el7.x86_64                         4/4 
  Verifying  : 3:docker-ce-20.10.7-3.el7.x86_64                             1/4 
  Verifying  : 1:docker-ce-cli-20.10.7-3.el7.x86_64                         2/4 
  Verifying  : docker-ce-rootless-extras-20.10.7-3.el7.x86_64               3/4 
  Verifying  : docker-scan-plugin-0.8.0-3.el7.x86_64                        4/4 

Removed:
  docker-ce.x86_64 3:20.10.7-3.el7                                              
  docker-ce-cli.x86_64 1:20.10.7-3.el7                                          
  docker-ce-rootless-extras.x86_64 0:20.10.7-3.el7                              

Dependency Removed:
  docker-scan-plugin.x86_64 0:0.8.0-3.el7                                       

Complete!

Docker CE is a community version, which has not been verified by kubernetes. There may be compatibility problems!


Read More: